Scheduled for May 22, 2025 at 2:08 PM – 2:35 PM
Affects
eezi core
Under maintenance from 2:08 PM to 2:35 PM
Completed
May 22, 2025 at 2:35 PMCompleted
May 22, 2025 at 2:35 PMMaintenance has completed successfully.
In progress
May 22, 2025 at 2:08 PMIn progress